以下不做特殊声明都是root用户执行
#升级GCC
    yum -y install gcc-c++ openssl-devel
    完毕之后,我们输入gcc -v检查是否有出现版本号,如果有说明没有问题。
    变态的是,nodejs4.0需要gcc版本大于4.8,可是yum是安装不到4.8的,所以需要手工升级gcc到最新版本(4.9.2)
    cd /usr/local/src
    tar -jxvf gcc-4.9.2.tar.bz2
    cd gcc-4.9.2
    ./contrib/download_prerequisites(下载依赖)
    mkdir gcc-build-4.9.2(创建build目录)
    cd gcc-build-4.9.2
    ../gcc-4.9.2/configure -enable-checking=release -enable-languages=c,c++ -disable-multilib(生成makefile)
    make -j4(开始编译,-j4选项是make对多核处理器的优化,如果不成功请使用 make)
    make install
    重启,然后gcc -v 查看版本,显示4.9.2,升级成功
#错误的提前处理
    如果至此就开始安装nodejs 4.0,当完成后执行node -v查看版本时会提示如下错误:
    可以提前解决这个问题。实际上,当升级到最新版Gcc之后,这两个文件是有的,只是链接的不对,不信请执行
    strings /usr/local/lib64/libstdc++.so.6.0.20|grep GLIBCXX,发现15和20都是存在的
    
    开始解决:
    cp /usr/local/lib64/libstdc++.so.6.0.20 /usr/lib64/
    cd /usr/lib64/
    rm -f libstdc++.so.6
    ln -s libstdc++.so.6.0.20 libstdc++.so.6
    搞定收工,请执行如下命令验证:
    strings /usr/lib64/libstdc++.so.6 | grep GLIBCXX
    发现已经都出现了
#检查python版本(nodejs需要python版本 >= v2.5.0 & < 3.0.0)
    先看是否已经安装了python
    rpm -qa | grep python
    我的已经安装了,所以需要查看版本
    python –version
    我的系统显示版本为2.6.6,满足条件
#下载最新版Nodejs的源码(截止到2015年9月9日,最新源码是v4.0,21.46M)
    cd /usr/local/src
    wget http://nodejs.org/dist/v4.0.0/node-v4.0.0.tar.gz
#解压缩、配置、编译、安装
    tar -zxvf node-v4.0.0.tar.gz
    cd node-v4.0.0/
    ./configure
    make && make install
    时间稍长,可以溜达一圈
    验证安装是否成功请执行,node -v,如果有版本显示,就是安装成功了
    然后删除没用的文件
    rm -rf /usr/local/src/node-v4.0.0/
    rm -rf /usr/local/src/node-v4.0.0.tar.gz